Project

General

Profile

VisiCut » History » Version 11

Anonymous, 2012-07-13 17:57

1 1 bartb
h1. LaOS Visicut User Guide
2 1 bartb
3 5 bartb
{{>toc}}
4 5 bartb
5 1 bartb
VISICUT is a stand-alone control program that accepts a file to be cut out from any 2D drawing program to. It is made by "Thomas Oster":http://visicut.wordpress.com
6 1 bartb
7 1 bartb
8 1 bartb
Visicut is not a drawing program: once you have sent your drawing to Visicut you can no longer modify it, but still scale it. In Visicut you specify the settings for your cutter and for the material to cut. 
9 1 bartb
10 1 bartb
(LaOS can also be used with a printer driver inside a 2D drawing program like Inkscape, as described elsewhere in this wiki).
11 1 bartb
12 1 bartb
13 5 bartb
14 5 bartb
h2. Installing Visicut
15 5 bartb
16 1 bartb
Available for all platforms from http://visicut.wordpress.com/download and install.
17 1 bartb
18 5 bartb
h2. Selecting the HPC
19 1 bartb
20 1 bartb
* Open the Visicut app and go to File -> Advanced -> Manage Lasercutters... and select LAOS HPC. 
21 1 bartb
* Click Edit. A window appears with settings for the HPC. 
22 1 bartb
* If you do not see the following values in the window (pic to follow, but settings are here too) edit them and Save
23 3 bartb
24 1 bartb
p=. !SettingsHPC.png!
25 1 bartb
26 1 bartb
* On the Visicut screen select LAOS HPC as lasercutter. Below that you might see dimensions like 300 x 600 mm, but those have to do with the materials settings, not the bed setting, so do not worry.
27 1 bartb
28 5 bartb
h2. First move
29 1 bartb
30 9 bartb
* Now draw something - a square will be fine - in your drawing program, save it as a .svg file and open it with File -> Open in Visicut. It will appear in the colored window.
31 1 bartb
* If you do not see it, click 'Everything => Cut Line' in the mapping box and verify that 'Cutting' in the topleft is tacked.
32 3 bartb
33 1 bartb
p=. !cutline.png! 
34 1 bartb
35 1 bartb
* You can move the square around and scale it. Position it some 10 cms from the left and top. 
36 1 bartb
* Now leave the lid of your lasercutter open and click Execute. The job will be sent to the cutter. 
37 1 bartb
* Neglect the pop-up window about closing the lid etc., just hit OK. The laser head should now draw the square.
38 1 bartb
39 5 bartb
h2. Setting speed and power
40 4 bartb
41 2 bartb
* Before you can cut you need the set the power and the speed for the selected material, there are some predefined settings under Material.
42 1 bartb
* You can also experiment with settings on the go.
43 2 bartb
* Then tack ‘Edit settings before Executing” and hit ‘Execute' again. 
44 2 bartb
* A window will pop up where you can edit the settings for your specific material. 
45 1 bartb
46 1 bartb
47 1 bartb
p=. !edit.png!
48 1 bartb
49 1 bartb
50 1 bartb
* OK will sent your job to the printer. And you can choose to keep this setting if you wish.
51 5 bartb
* material settings for the LS3020 are in the (future) Laser Cuttings section
52 5 bartb
53 5 bartb
54 6 bartb
55 6 bartb
h2. How to use VisiCut with Inkscape
56 6 bartb
57 6 bartb
This "tutorial":http://hci.rwth-aachen.de/visicut_and_inkscape explains how to create SVG files with Inkscape that have different layers.
58 6 bartb
This "second tutorial":http://hci.rwth-aachen.de/visicut_cut_and_engrave how to open files with cut and engrave layers with VisiCut.
59 6 bartb
60 6 bartb
h2. Printing directly from Inkscape
61 6 bartb
62 10 bartb
A plug-in to directly cut from Inkscape can be installed following these "instructions":http://hci.rwth-aachen.de/visicut_inkscape_plugin. A Lasercut Path will be added under the Extensions tab. 
63 6 bartb
64 7 bartb
p=. !openwithvisicut.png!
65 1 bartb
66 10 bartb
If you want to cut, be sure Visicut is running before you select Open with VisiCut. 
67 7 bartb
68 11 Anonymous
h2. Add a new material setting
69 11 Anonymous
70 11 Anonymous
Suppose you want to include a new material in the Materials List. Say Beech of 0.8 mm, with setting of Speed 100 and Power 70 at 2500 Hz.
71 11 Anonymous
72 11 Anonymous
Go to Edit->Advanced->Manage Materials...
73 11 Anonymous
74 11 Anonymous
p=. !manage.png!
75 11 Anonymous
76 11 Anonymous
Then select your lasercutter
77 11 Anonymous
78 11 Anonymous
p=. !laoshpc.png!
79 11 Anonymous
80 11 Anonymous
A list will appear with all the materials Visicut already knows.
81 11 Anonymous
82 11 Anonymous
p=. !materials.png!
83 11 Anonymous
84 11 Anonymous
Beech is not yet in the list, so we click + on the right. A new dialog appears:
85 11 Anonymous
86 11 Anonymous
p=. !unnamedmaterial.png!
87 11 Anonymous
88 11 Anonymous
Here we enter the information we have for Beech 0.8 mm. Name Beech 0.8 mm, description thin wood or so. Thickness is in our case 0.8 mm. Now the dialog looks like this and we have to enter the parameters, to start with 'cut line'. So select 'cut line' and press Edit.
89 11 Anonymous
90 11 Anonymous
p=. !beech.png!
91 11 Anonymous
92 11 Anonymous
93 11 Anonymous
94 11 Anonymous
95 11 Anonymous
96 11 Anonymous
97 11 Anonymous
    Wir tragen hier nun die Informationen ein, die wir über Buche 0,8mm haben: Name ist wohl Buche 0,8mm, als Description geben wir dünnes Holz oder so ein. Thickness beschreibt die Materialstärke in unserem Fall also 0.8mm. Der Dialog sollte nun wie folgt aussehen und wir wollen die Parameter des Materials als nächstes bearbeiten. Konkret: Cut Line soll bearbeitet werden. Also Cut Line in der Liste auswählen und den Edit Knopf drücken: 
98 11 Anonymous
99 7 bartb
100 7 bartb
101 7 bartb
h2. todo
102 7 bartb
103 7 bartb
Visicut: how to set your own materials settings, translation of http://hci.rwth-aachen.de/visicut_addMaterials_de