Project

General

Profile

Etching issue

Added by DeanoC over 5 years ago

Hi,

Our Laos Laser (converted from a KIII-40) has issues when it does bitmap etching OR bitmap marking (i.e. simplecode outputs G move commands for the pixel data). It even occurs for a solid rectangle :/

When a wireframe rectangle is drawn (standard vector box) its perfect, but when its filled (so shuttling back and forth left to right) it drifts to the right as it goes down the page and stops short of the proper length.

I have a feeling its something to do with power, but so far stumped. I've tried adjusting Pololu's but whiles it makes different sounds and can stop the laser working altogether it doesn't seem to help. I've tried changed the config settings for speed, acceleration etc.

My current guess, is that the PSU is not supplying enough current, so when its using extra power shuttling back and forth doing a raster etch it can't supply the current and so comes short. I've measured the Vmot and it changes, varying from about 16V when idle, upto 25V when homing, is it normal that Vmot should vary?

Any ideas, greatly recieved as tbh its driving me to even consider going back to moshidraw :O

Deano


Replies (7)

RE: Etching issue - Added by jaap over 5 years ago

Hi Deano,

Are you sure you're using the latest firmware? Skipping to one side happened before due to a firmware problem.

Try downloading this version:
https://github.com/LaosLaser/Firmware/blob/mbed-gcc/laoslaser-03-01-2014.bin

Jaap

RE: Etching issue - Added by DeanoC over 5 years ago

Just tried the latest firmware and does the same thing. Snapped a quick photo with my phone to show exactly what I mean.

The outlines such as the wire frame box and circle are perfect but the filled aren't.The bottom right ones is the same square just type of cut changed in visi cut from mark to etch.

CAM00115.jpg View (1.62 MB)

RE: Etching issue - Added by peteruithoven over 5 years ago

I can't reproduce the issue on both our Morntech or HPC LS3020 lasercutters.
http://fablabamersfoort.nl/fotos/index.php/11-Jul-2013
http://fablabamersfoort.nl/fotos/index.php/image
http://fablabamersfoort.nl/fotos/index.php/13-Aug-2013

I never use the 3D engraving btw, had to much troubles with it.

Makes me think the issue is in hardware.

RE: Etching issue - Added by jaap over 5 years ago

Hi Deano,

What software (and version) are you using to create the engraving? Are you using the printer driver or Visicut? The error is so regular that I think it must be a software issue somewhere.

Jaap

RE: Etching issue - Added by DeanoC over 5 years ago

Hi Jaap,

Latest downloadable version of visicut and firmware. I've checked the simplecode output and its outputting correct codes both using bitmap and vector mode.
Pretty certain its HW or firmware, that fact no-one else is seeing it, seems to indicate HW :/

I think it might be a PSU problem? but not really sure. The Vmot voltage is varying quite a bit 16-23V, not sure if thats normal or sign the power supply is busted.

Thanks,
Deano

RE: Etching issue - Added by Springuin over 5 years ago

Deano,

Some additional thoughts:
- Vmot variation sounds wrong; however if it's a cheap 16V power supply it could be that the no-load output voltage is much higher than under load. Sudden drops of the voltage could possibly confuse the hardware. You could try to power the board from a lab power supply or an ATX power supply.
- Maybe measuring and monitoring the other voltages gives a clue
- Maybe your stepping frequency is a little too high
- Maybe your wiring is not completely sound and the modulation of the laser during etching interferes with other signals or the high current wires are too thin for their load.

RE: Etching issue - Added by peteruithoven over 5 years ago

You might also want to check configurations like:
- motion.tolerance
- x.invert
- y.invert

If the lasercutter moves really fast you could try to lower the acceleration and speed, but that's probably not the solution.

More info:
http://redmine.laoslaser.org/projects/laos/wiki/LAOS_configuration_file

    (1-7/7)