path issue

Added by david.eickhoff almost 11 years ago

Hi there, I found the time to connect the pwm and did a few more testing. I think the pwm works but I have issues with the testpattern regarding the path (see image)
I used a 5x5 testpattern which was generated by the testpattern laserscript someone posted here already. As you can see, the rectangles are not being drawn completely. I used the latest git checkout but also tried the last firmware from 2012..

I think this has something to do with the PWM but I am not sure.. I used a 1.1kOhm pull-up resistor between 5V and IN as suggested in the wiki.

Do you have any idea what could cause this?

testpatter visicut

Foto.JPG (87.2 KB) Foto.JPG testpatter visicut

Replies (3)

RE: path issue - Added by peteruithoven almost 11 years ago

Hi David,

I have no good glue what would cause these blocks to be positioned this weird. It's probably not that the lasercutter is inaccurate, because the blocks are okay shape wise.
What happens if you lasercut something else with a few seperate shapes?

RE: path issue - Added by david.eickhoff almost 11 years ago

mhm I removed the PWM connection and the testpattern works fine again..

Here is how I connected the pwm output (see pictures):

E (on laos) -> G
C (on laos) -> IN

1.1kOhm between IN and 5V

origin.jpg (129 KB) origin.jpg original connector
pins.jpg (111 KB) pins.jpg connector pins
laos_pwm.jpg (120 KB) laos_pwm.jpg connected to laos pwm

RE: path issue - Added by david.eickhoff almost 11 years ago

oh.. I connected the pwm again and now it works also fine. without any changes in the config or code..

maybe the pull-up resistor was not connected properly so the power came through the laos board which was too much and caused the laos board (and the mbed) to loose some bits and bytes...

my test pattern works now :) great - and thanks for your fast response!