Project

General

Profile

Bug #34

job regularly hangs

Added by Anonymous almost 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
firmware
Target version:
-
Start date:
2012-08-25
Due date:
% Done:

0%


Description

From the forum, file stops running:

When I execute a file, it stops running at some point.
Never the same point in the file, though.
The display still says: RUNNING 1%
But the machine quits.It doesn't resume.

I've also observed this on my laser cutter, problem is definitely intermittent and hard to reproduce reliably.

Seems like either a hardware or a firmware interrupt problem, since the same job doesn't always hang, nor in the same place.

Might be an idea to set up a single test job which hangs, and then try it on different units.

This also brings up the need for a diagnostic mode (w/ docs), so that we have at least some chance of figuring problems like this out.

History

#1 Updated by peter almost 8 years ago

We have found some pointers to this problem:
1) I2C communication with display.
2) Possible power drops on 5V of the laser power supply
3) Interrupts due to heavy ethernet communication

Possible remedies:
1) Disconnect the I2C display (it is reported that the laser resumes when you do this while it hangs)
you may want to disable it also in the config file (set sys.nodisplay 1)
2) Connect 5V to separate 5V power supply
3) Disconnect the ethernet while lasering

If you observe these problems, please report:
1) Firmware version?
2) Do you have an I2C display?
3) Did disconnecting the Ethernet help?

#2 Updated by david over 7 years ago

I've been using JCW's laser cutter for a few hours today with no hangs or freezes whatsoever. If the issue reappears I'll try disconnecting either the I2C display or the ethernet cable (or both).

#3 Updated by Daid over 7 years ago

I've had 3 crashes yesterday during cutting. All 3 happened after I touched the display on the Amersfoort Fablab Laos laser.

I think there is an ESD problem with the display hardware. The plexiglass used to hold the display in that laser makes it easy to build up a static charge, which could disrupt the AVR controller on the display if it discharges trough one of the IO pins or even power or ground.

#4 Updated by hugomeiland about 7 years ago

  • Status changed from New to Closed

no updates here for months, new firmware has been stable on several machines; closing this one....

Also available in: Atom PDF